RubyGems Navigation menu

navigable 1.4.0

A stand-alone tool for isolating business logic from external interfaces and cross-cutting concerns. Navigable composes self-configured command and observer objects to allow you to extend your business logic without modifying it. Navigable is compatible with any Ruby-based application development framework, including Rails, Hanami, and Sinatra.

Versions:

  1. 1.5.2 - April 14, 2022 (12.5 KB)
  2. 1.5.1 - December 23, 2020 (13.5 KB)
  3. 1.5.0 - December 06, 2020 (13.5 KB)
  4. 1.4.0 - October 04, 2020 (13.5 KB)
  5. 1.3.0 - September 29, 2020 (13.5 KB)
Show all versions (14 total)

Runtime Dependencies (2):

Development Dependencies (5):

Owners:

Pushed by:

Authors:

  • Alan Ridlehoover, Fito von Zastrow

SHA 256 checksum:

8320c574abd8516e28364c792273f51cd3830fadaaa750387841f5c11b44e752

Total downloads 13,676

For this version 1,005

Gemfile:
= Copy to clipboard Copied!

install:
=

License:

MIT

Required Ruby Version: >= 2.3.0

Links: