RubyGems Navigation menu

omniauth-rails_csrf_protection 1.0.0

This gem provides a mitigation against CVE-2015-9284 (Cross-Site Request Forgery on the request phrase when using OmniAuth gem with a Ruby on Rails application) by implementing a CSRF token verifier that directly utilize `ActionController::RequestForgeryProtection` code from Rails.

Versions:

  1. 1.0.0 - January 14, 2021 (10,5 ko)
  2. 0.1.2 - June 04, 2019 (10,5 ko)
  3. 0.1.1 - June 02, 2019 (10,5 ko)
  4. 0.1.0 - May 30, 2019 (10,5 ko)

Dépendances de Runtime (2):

Dépendances de Development (4):

Propriétaires:

Pushed by:

Auteurs:

  • Cookpad Inc.

Total de contrôle SHA 256:

3f63b2fb2820e99b0cc41b58169d96fd8e6ee29c38b05f3dde23568f53198b8f

Total de téléchargements 8 372 497

Pour cette version 2 179 353

Gemfile:
= Copier Copié!

installation:
=

License:

MIT

Version de Ruby requise: >= 0

Liens: