RubyGems Navigation menu

opensearch-aws-sigv4 1.2.1

A wrapper for opensearch-ruby gem that provides AWS Sigv4 signing. It behaves like OpenSearch::Client, but signs every request with AWS Sigv4 using the credentials provided during the client's initialization.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 1.2.1 - October 03, 2023 (16.5 KB)
  2. 1.2.0 - February 28, 2023 (17.5 KB)
  3. 1.1.0 - January 20, 2023 (17.5 KB)
  4. 1.0.0 - November 30, 2022 (17 KB)
Show all versions (5 total)

Runtime Dependencies (2):

aws-sigv4 >= 1
opensearch-ruby >= 1.0.1

Owners:

Pushed by:

Authors:

  • OpenSearch Contributors

SHA 256 checksum:

= Copy to clipboard Copied!

Signature validity period:

August 24, 2023 - August 23, 2024

Total downloads 657,348

For this version 503,560

License:

Apache-2.0

Required Ruby Version: >= 2.4

Links: