RubyGems Navigation menu

pco_api 1.3.0

pco_api is a gem for working with the RESTful JSON API at api.planningcenteronline.com using HTTP basic auth or OAuth 2.0. This library can talk to any endpoint the API provides, since it is written to build endpoint URLs dynamically using method_missing.

Versions:

  1. 2.0.1 - August 08, 2022 (9.5 KB)
  2. 2.0.0 - March 01, 2021 (9.5 KB)
  3. 1.3.1 - March 01, 2021 (9 KB)
  4. 1.3.0 - September 21, 2020 (9 KB)
  5. 1.2.2 - August 17, 2017 (9 KB)
Show all versions (11 total)

Runtime Dependencies (3):

  • excon >= 0.71.0
  • faraday ~> 0.10
  • faraday_middleware ~> 0.10
  • Development Dependencies (3):

  • pry ~> 0.10
  • rspec ~> 3.2
  • webmock ~> 1.21
  • Owners:

    Pushed by:

    Authors:

    • Planning Center Online

    SHA 256 checksum:

    bb3961f6f781880ae843c64f5b0d92127896fa07d1293081b8cc1574bfa24724

    Total downloads 20,889

    For this version 1,200

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.0.0

    Links: