RubyGems Navigation menu

pg 0.15.0.pre.454

Pg is the Ruby interface to the {PostgreSQL RDBMS}[http://www.postgresql.org/]. It works with {PostgreSQL 8.3 and later}[http://bit.ly/6AfPhm]. A small example usage: #!/usr/bin/env ruby require 'pg' # Output a table of current connections to the DB conn = PG.connect( dbname: 'sales' ) conn.exec( "SELECT * FROM pg_stat_activity" ) do |result| puts " PID | User | Query" result.each do |row| puts " %7d | %-16s | %s " % row.values_at('procpid', 'usename', 'current_query') end end

Versions:

  1. 0.19.0.pre20160820113039 - August 20, 2016 x86-mingw32 (1.52 MB)
  2. 0.19.0.pre20160820113039 - August 20, 2016 x64-mingw32 (1.72 MB)
  3. 0.19.0.pre20160820113039 - August 20, 2016 (222 KB)
  4. 0.19.0.pre20160817083826 - August 18, 2016 x86-mingw32 (1.52 MB)
  5. 0.19.0.pre20160817083826 - August 18, 2016 x64-mingw32 (1.72 MB)
Show all versions (104 total)

Authors:

  • Michael Granger

Owners:

Feef2024584d97a97338b964661ca795Abc11c007a3a284272d261b2dae6376e04cdb622ce0aac272b61f23f373e2abf

SHA 256 checksum:

beaf7daed1c117d3cd7530bbe275ba9a94331fa0730e2755ce08618babf51da5

Total downloads 26,510,735

For this version 1,274

Gemfile:
= Copy to clipboard Copied!

install:
=

Licenses:

BSD, Ruby, GPL

Required Ruby Version: None

Required Rubygems Version: > 1.3.1

Links: