RubyGems Navigation menu

pg 0.17.0-x86-mingw32

Pg is the Ruby interface to the {PostgreSQL RDBMS}[http://www.postgresql.org/]. It works with {PostgreSQL 8.4 and later}[http://www.postgresql.org/support/versioning/]. A small example usage: #!/usr/bin/env ruby require 'pg' # Output a table of current connections to the DB conn = PG.connect( dbname: 'sales' ) conn.exec( "SELECT * FROM pg_stat_activity" ) do |result| puts " PID | User | Query" result.each do |row| puts " %7d | %-16s | %s " % row.values_at('procpid', 'usename', 'current_query') end end

Versions:

  1. 0.18.2 - May 15, 2015 x64-mingw32 (1.58 MB)
  2. 0.18.2 - May 15, 2015 x86-mingw32 (1.3 MB)
  3. 0.18.2 - May 14, 2015 (212 KB)
  4. 0.18.1 - January 6, 2015 x86-mingw32 (1.45 MB)
  5. 0.18.1 - January 6, 2015 x64-mingw32 (1.43 MB)
Show all versions (90 total)

Authors:

  • Michael Granger, Lars Kanis

Owners:

Feef2024584d97a97338b964661ca795Abc11c007a3a284272d261b2dae6376e04cdb622ce0aac272b61f23f373e2abf

Sha 256 checksum:

9b5a1b7065502e6c9d176063c74c29382d2f75df707e7237730b6be63edf9cbb

Total downloads 16,257,367

For this version 13,822

Show all versions (90 total)

Required Ruby Version: None

Licenses:

BSD, Ruby, GPL

Gemfile:
= Copy to clipboard Copied!

install:
= Copy to clipboard Copied!

Links: