RubyGems Navigation menu

pronto 0.11.2

Pronto runs analysis quickly by checking only the relevant changes. Created to be used on pull requests, but suited for other scenarios as well. Perfect if you want to find out quickly if branch introduces changes that conform to your styleguide, are DRY, don't introduce security holes and more.

Gemfile:
= Copiar al portapapeles ¡Copiado!

instalar:
=

Versiones:

  1. 0.11.2 - October 30, 2023 (31,5 KB)
  2. 0.11.1 - December 31, 2022 (31 KB)
  3. 0.11.0 - January 31, 2021 (29,5 KB)
  4. 0.10.0 - February 03, 2019 (26,5 KB)
  5. 0.9.5 - August 15, 2017 (25,5 KB)
Mostrar todas las versiones (45 total)

dependencias de Runtime (7):

gitlab >= 4.4.0, < 5.0
httparty >= 0.13.7, < 1.0
octokit >= 4.7.0, < 8.0
rainbow >= 2.2, < 4.0
rexml >= 3.2.5, < 4.0
rugged >= 0.23.0, < 2.0
thor >= 0.20.3, < 2.0

dependencias de Development (8):

bundler >= 1.15
pronto-rubocop ~> 0.10.0
rake ~> 12.0
rspec ~> 3.4
rspec-its ~> 1.2
rubocop ~> 0.58
simplecov ~> 0.17, != 0.18.0, != 0.18.1, != 0.18.2, != 0.18.3, != 0.18.4, != 0.18.5, != 0.19.0, != 0.19.1

Propietarios:

Subida por:

Autores:

  • Mindaugas Mozūras

SHA 256 checksum:

= Copiar al portapapeles ¡Copiado!

Total de descargas 11.368.815

Para esta versión 557.197

Licencia:

MIT

Versión de Ruby requerida: >= 2.3.0

Enlace: