RubyGems Navigation menu

puma-daemon 0.3.2

In version 5.0 the authors of the popular Ruby web server Puma chose to remove the daemonization support from Puma, because the code wasn't wall maintained, and because other and better options exist for production deployments. For example systemd, Docker/Kubernetes, Heroku, etc. Having said that, it was neat and often useful to daemonize Puma in development. This gem adds this support to Puma 5 & 6 (hopefully) without breaking anything in Puma itself. So, if you want to use the latest and greatest Puma 5+, but prefer to keep using built-in daemonization, this gem if for you.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 0.3.2 - June 22, 2023 (77.5 KB)
  2. 0.3.0 - March 14, 2023 (77.5 KB)
  3. 0.2.3 - March 14, 2023 (77.5 KB)
  4. 0.2.2 - March 07, 2023 (16.5 KB)
  5. 0.1.2 - March 05, 2021 (14 KB)
Show all versions (10 total)

Runtime Dependencies (2):

puma >= 5.0
rack >= 0

Development Dependencies (8):

codecov >= 0
httparty >= 0
rspec-its >= 0
rubocop >= 0
simplecov >= 0
yard >= 0

Owners:

Pushed by:

Authors:

  • Konstantin Gredeskoul

SHA 256 checksum:

= Copy to clipboard Copied!

Total downloads 771,011

For this version 283,605

License:

MIT

Required Ruby Version: >= 2.4.0

New versions require MFA: true

Version published with MFA: true

Links: