RubyGems Navigation menu

rack-pack 0.3.1

Rack::Pack is a piece of Rack Middleware that packages and optionally compresses assets such as javascripts and stylesheets into single files. In a development environment, assets will be packaged on each request if there have been changes to the source files. In a production environment, assets will only be packaged one time, and only if there have been changes.

Versions:

  1. 0.3.2 - August 30, 2011 (12 KB)
  2. 0.3.1 - May 18, 2011 (12 KB)
  3. 0.3.0 - May 18, 2011 (11.5 KB)
  4. 0.2.2 - November 11, 2010 (11 KB)
  5. 0.2.1 - August 30, 2010 (11 KB)

Runtime Dependencies (1):

  • rack ~> 1.2.1
  • Development Dependencies (10):

  • activesupport ~> 3.0.7
  • closure-compiler ~> 0.3.2
  • i18n ~> 0.5.0
  • jsmin ~> 1.0.1
  • packr ~> 3.1.0
  • rainpress ~> 1.0.0
  • rspec ~> 2.6.0
  • test-construct ~> 1.2.0
  • uglifier ~> 0.5.3
  • yui-compressor ~> 0.9.1
  • Owners:

    Authors:

    • Pete Browne

    SHA 256 checksum:

    0cbd46f13e3585ecccc1613b4d38a94e5f4d9f760022efedfaa1420fdf0140a9

    Total downloads 13,515

    For this version 2,398

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    Licenses:

    N/A

    Required Ruby Version: None

    Required Rubygems Version: >= 1.3.6

    Links: