RubyGems Navigation menu

rubocop 0.24.0

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.17.0 - June 15, 2021 (483 KB)
  2. 1.16.1 - June 09, 2021 (482 KB)
  3. 1.16.0 - June 01, 2021 (482 KB)
  4. 1.15.0 - May 17, 2021 (480 KB)
  5. 1.14.0 - May 05, 2021 (478 KB)
  6. 0.24.0 - June 25, 2014 (265 KB)
Show all versions (180 total)

Runtime Dependencies (5):

  • json < 2, >= 1.7.7
  • parser < 3.0, >= 2.2.0.pre.2
  • powerpack ~> 0.0.6
  • rainbow < 3.0, >= 1.99.1
  • ruby-progressbar ~> 1.4
  • Development Dependencies (5):

  • bundler ~> 1.3
  • rake ~> 10.1
  • rspec ~> 3.0
  • simplecov ~> 0.7
  • yard ~> 0.8
  • Owners:

    Authors:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    d27a16864c907fd7a1ea463c6cc4ccbda6671b12255e497fceaa080315f0c90d

    Total downloads 164,248,473

    For this version 38,532

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 1.9.2

    Links: