RubyGems Navigation menu

rubocop 0.44.1

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.0.0 - October 21, 2020 (424 KB)
  2. 0.93.1 - October 12, 2020 (422 KB)
  3. 0.93.0 - October 08, 2020 (421 KB)
  4. 0.92.0 - September 25, 2020 (420 KB)
  5. 0.91.1 - September 23, 2020 (419 KB)
  6. 0.44.1 - October 13, 2016 (269 KB)
Show all versions (153 total)

Runtime Dependencies (5):

  • parser < 3.0, >= 2.3.1.1
  • powerpack ~> 0.1
  • rainbow < 3.0, >= 1.99.1
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.0.1, ~> 1.0
  • Development Dependencies (1):

  • bundler ~> 1.3
  • Owners:

    Authors:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    2f702937dce43bed412c186dadd3727a769e837bd82263ee7687f37050c324ec

    Total downloads 121,552,478

    For this version 430,055

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.0.0

    Links: