RubyGems Navigation menu

rubocop 0.51.0

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.33.0 - August 04, 2022 (546 KB)
  2. 1.32.0 - July 21, 2022 (544 KB)
  3. 1.31.2 - July 07, 2022 (541 KB)
  4. 1.31.1 - June 29, 2022 (541 KB)
  5. 1.31.0 - June 27, 2022 (541 KB)
  6. 0.51.0 - October 18, 2017 (333 KB)
Show all versions (213 total)

Runtime Dependencies (6):

  • parallel ~> 1.10
  • parser < 3.0, >= 2.3.3.1
  • powerpack ~> 0.1
  • rainbow < 3.0, >= 2.2.2
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.0.1, ~> 1.0
  • Development Dependencies (1):

  • bundler ~> 1.3
  • Owners:

    Authors:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    c131a5c063600cd31cf49c69130c16b94a6bd7d6a35f6f00c587ac6330bdc233

    Total downloads 247,976,880

    For this version 3,253,650

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.1.0

    New versions require MFA: true

    Links: