RubyGems Navigation menu

rubocop 0.57.2

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.18.4 - July 23, 2021 (488 ko)
  2. 1.18.3 - July 06, 2021 (488 ko)
  3. 1.18.2 - July 02, 2021 (487 ko)
  4. 1.18.1 - June 30, 2021 (487 ko)
  5. 1.18.0 - June 29, 2021 (487 ko)
  6. 0.57.2 - June 12, 2018 (391 ko)
Voir toutes les versions (185)

Dépendances de Runtime (7):

  • jaro_winkler ~> 1.5.1
  • parallel ~> 1.10
  • parser >= 2.5
  • powerpack ~> 0.1
  • rainbow < 4.0, >= 2.2.2
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.0.1, ~> 1.0
  • Dépendances de Development (2):

  • bundler ~> 1.3
  • rack < 2.0, >= 1.6.9
  • Propriétaires:

    Auteurs:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    Total de contrôle SHA 256:

    468ca03be186a4c39f75535ad445bb073408cf2c75035105ac6b91dc04d9cbac

    Total de téléchargements 171 986 027

    Pour cette version 1 995 453

    Gemfile:
    = Copier Copié!

    installation:
    =

    License:

    MIT

    Version de Ruby requise: >= 2.1.0

    Liens: