RubyGems Navigation menu

rubocop 1.19.0

RuboCop is a Ruby code style checking and code formatting tool. It aims to enforce the community-driven Ruby Style Guide.

Versões:

  1. 1.23.0 - November 15, 2021 (511 KB)
  2. 1.22.3 - October 27, 2021 (508 KB)
  3. 1.22.2 - October 22, 2021 (508 KB)
  4. 1.22.1 - October 04, 2021 (507 KB)
  5. 1.22.0 - September 29, 2021 (506 KB)
  6. 1.19.0 - August 12, 2021 (493 KB)
Mostrar todas as versões (194)

Runtime Dependencies (8):

  • parallel ~> 1.10
  • parser >= 3.0.0.0
  • rainbow >= 2.2.2, < 4.0
  • regexp_parser >= 1.8, < 3.0
  • rexml >= 0
  • rubocop-ast >= 1.9.1, < 2.0
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.4.0, < 3.0
  • Development Dependencies (1):

  • bundler >= 1.15.0, < 3.0
  • Donos:

    Pushed by:

    Autores:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    4ea67b3e0581623e40cfcb58cdb946d11d2aa92b78d42cd050ab6d786d36a716

    Total de downloads 195.112.317

    Desta versão 309.181

    Gemfile:
    = Copy to clipboard Copied!

    instalar:
    =

    Licença:

    MIT

    Versão Requerida do Ruby: >= 2.5.0

    Requires MFA accounts: 1.23.0

    Links: