RubyGems Navigation menu

rubocop 1.34.0

RuboCop is a Ruby code style checking and code formatting tool. It aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.39.0 - November 14, 2022 (564 KB)
  2. 1.38.0 - November 01, 2022 (563 KB)
  3. 1.37.1 - October 24, 2022 (560 KB)
  4. 1.37.0 - October 20, 2022 (559 KB)
  5. 1.36.0 - September 01, 2022 (555 KB)
  6. 1.34.0 - August 09, 2022 (548 KB)
Show all versions (222 total)

Runtime Dependencies (9):

  • json ~> 2.3
  • parallel ~> 1.10
  • parser >= 3.1.2.1
  • rainbow >= 2.2.2, < 4.0
  • regexp_parser >= 1.8, < 3.0
  • rexml >= 3.2.5, < 4.0
  • rubocop-ast >= 1.20.0, < 2.0
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.4.0, < 3.0
  • Development Dependencies (1):

  • bundler >= 1.15.0, < 3.0
  • Owners:

    Pushed by:

    Authors:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    c794b2713af8017c3e17941ae42c99000d4188fdfc164fb033c67f8dec1e3f0a

    Total downloads 278,197,034

    For this version 40,283

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.6.0

    New versions require MFA: true

    Version published with MFA: true

    Links: