RubyGems Navigation menu

rubocop 1.61.0

RuboCop is a Ruby code style checking and code formatting tool. It aims to enforce the community-driven Ruby Style Guide.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 1.64.0 - May 23, 2024 (626 KB)
  2. 1.63.5 - May 09, 2024 (623 KB)
  3. 1.63.4 - April 28, 2024 (623 KB)
  4. 1.63.3 - April 22, 2024 (623 KB)
  5. 1.63.2 - April 16, 2024 (623 KB)
  6. 1.61.0 - February 29, 2024 (617 KB)
Show all versions (272 total)

Runtime Dependencies (10):

json ~> 2.3
parallel ~> 1.10
parser >= 3.3.0.2
rainbow >= 2.2.2, < 4.0
regexp_parser >= 1.8, < 3.0
rexml >= 3.2.5, < 4.0
rubocop-ast >= 1.30.0, < 2.0
unicode-display_width >= 2.4.0, < 3.0

Owners:

Pushed by:

Authors:

  • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

SHA 256 checksum:

0c35a94bc6c088205d525b8082affd3b412d75347faff52c1f71a6205301b48e

Total downloads 422,031,061

For this version 667,822

License:

MIT

Required Ruby Version: >= 2.7.0

New versions require MFA: true

Version published with MFA: true

Links: