RubyGems Navigation menu

sslshake 1.3.1

This is a library to simulate SSL and TLS handshake from SSLv2, SSLv3, to TLS 1.0-1.2. It does not rely on OpenSSL and is not designed as a replacement either. It targets full support for even older handshakes, which are not available in current releases of OpenSSL anymore. It also aims to be executable on all systems with a sufficiently modern version of Ruby without any additional requirements or pre-compiled binaries.

Versions:

  1. 1.3.1 - June 14, 2020 (13 KB)
  2. 1.3.0 - January 21, 2019 (11.5 KB)
  3. 1.2.0 - April 20, 2017 (11.5 KB)
  4. 1.1.0 - March 29, 2017 (11.5 KB)
  5. 1.0.13 - October 31, 2016 (11.5 KB)
Show all versions (6 total)

Owners:

Pushed by:

Authors:

  • Dominik Richter

SHA 256 checksum:

1069c97ed93441e1e1c167fb59f0eb952f64156784d9b321f60528d4f5747164

Total downloads 3,181,868

For this version 238,798

Gemfile:
= Copy to clipboard Copied!

install:
=

License:

MPL-2.0

Required Ruby Version: >= 0

Links: