RubyGems Navigation menu

sslshake 1.0.13

This is a library to simulate SSL and TLS handshake from SSLv2, SSLv3, to TLS 1.0-1.2. It does not rely on OpenSSL and is not designed as a replacement either. It targets full support for even older handshakes, which are not available in current releases of OpenSSL anymore. It also aims to be executable on all systems with a sufficiently modern version of Ruby without any additional requirements or pre-compiled binaries.

Versions:

  1. 1.3.0 - January 21, 2019 (11.5 KB)
  2. 1.2.0 - April 20, 2017 (11.5 KB)
  3. 1.1.0 - March 29, 2017 (11.5 KB)
  4. 1.0.13 - October 31, 2016 (11.5 KB)
  5. 1.0.12 - August 15, 2016 (11 KB)

Owners:

Authors:

  • Dominik Richter

SHA 256 checksum:

41d65da2bad48bd943aa38d8554567bd3827bc8ac7aed8a8046022814a477c38

Total downloads 2,736,027

For this version 76,719

Gemfile:
= Copy to clipboard Copied!

install:
=

License:

MPLv2

Required Ruby Version: >= 0

Links: