RubyGems Navigation menu

syncem 0.1.2

Sometimes you have an object that is not thread-safe, but you need to make sure each of its methods is thread-safe, because they deal with some resources, like files or databases and you want them to manage those resources sequentially. This small gem will help you achieve exactly that without any re-design of the objects you already have. Just decorate them with SyncEm decorator and that is it.

版本列表:

  1. 0.1.2 - June 23, 2019 (11.0 KB)
  2. 0.1.1 - April 13, 2019 (8.5 KB)
  3. 0.1.0 - March 06, 2019 (8.5 KB)

Development 依赖关系 (6):

  • minitest = 5.11.3
  • rake = 12.3.1
  • rdoc = 4.3.0
  • rubocop = 0.62.0
  • rubocop-rspec = 1.31.0
  • threads = 0.3.0
  • 所有者:

    作者:

    • Yegor Bugayenko

    SHA 256 checksum:

    c262ef7b59211891031015b5e97fc68ac6649ae70d02a2d8d57579914e11097b

    下载总次数 5,280

    这个版本 2,602

    Gemfile:
    = 复制到剪贴板 已复制

    安装:
    =

    许可:

    MIT

    需要的 Ruby 版本: >= 2.3

    相关链接: