RubyGems Navigation menu

sysexits 1.2.0

Have you ever wanted to call <code>exit()</code> with an error condition, but weren't sure what exit status to use? No? Maybe it's just me, then. Anyway, I was reading manpages late one evening before retiring to bed in my palatial estate in rural Oregon, and I stumbled across <code>sysexits(3)</code>. Much to my chagrin, I couldn't find a +sysexits+ for Ruby! Well, for the other 2 people that actually care about <code>style(9)</code> as it applies to Ruby code, now there is one! Sysexits is a *completely* *awesome* collection of human-readable constants for the standard (BSDish) exit codes, used as arguments to +exit+ to indicate a specific error condition to the parent process. It's so fantastically fabulous that you'll want to fork it right away to avoid being thought of as that guy that's still using Webrick for his blog. I mean, <code>exit(1)</code> is so passé! This is like the 14-point font of Systems Programming. Like the C header file from which this was derived (I mean forked, naturally), error numbers begin at <code>Sysexits::EX__BASE</code> (which is way more cool than plain old +64+) to reduce the possibility of clashing with other exit statuses that other programs may already return. The codes are available in two forms: as constants which can be imported into your own namespace via <code>include Sysexits</code>, or as <code>Sysexits::STATUS_CODES</code>, a Hash keyed by Symbols derived from the constant names. Allow me to demonstrate. First, the old way: exit( 69 ) Whaaa...? Is that a euphemism? What's going on? See how unattractive and... well, 1970 that is? We're not changing vaccuum tubes here, people, we're <em>building a totally-awesome future in the Cloud™!</em> include Sysexits exit EX_UNAVAILABLE Okay, at least this is readable to people who have used <code>fork()</code> more than twice, but you could do so much better! include Sysexits exit :unavailable Holy Toledo! It's like we're writing Ruby, but our own made-up dialect in which variable++ is possible! Well, okay, it's not quite that cool. But it does look more Rubyish. And no monkeys were patched in the filming of this episode! All the simpletons still exiting with icky _numbers_ can still continue blithely along, none the wiser.

Gemfile:
= 复制到剪贴板 已复制!

安装:
=

版本列表:

  1. 1.2.0 - August 08, 2014 (16.5 KB)
  2. 1.1.0 - September 18, 2012 (15.0 KB)
  3. 1.0.2 - December 23, 2010 (14.0 KB)
  4. 1.0.1 - October 14, 2010 (42.0 KB)
  5. 1.0.0 - June 19, 2010 (38.0 KB)

Development 依赖 (6):

hoe ~> 3.9
hoe-highline ~> 0.1.0
hoe-mercurial ~> 1.4.0
rdoc ~> 4.0
rspec ~> 2.11
simplecov ~> 0.6

业主:

作者:

  • Michael Granger

SHA 256 校验和:

598241c4ae57baa403c125182dfdcc0d1ac4c0fb606dd47fbed57e4aaf795662

下载总量 28,781,916

这个版本 28,761,641

许可:

BSD

需要的 Ruby 版本: >= 1.8.7

链接: