RubyGems Navigation menu

trent 0.5.0

I have been using Travis-CI for a few years to build, test, and deploy my apps. Bash is great, but using a higher level language for interacting with Travis and the build machine would be very beneficial. Trent is a convenient ruby gem that helps you execute system shell scripts with as little code *and pain* as possible.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 0.5.0 - December 04, 2019 (12 KB)
  2. 0.4.0 - March 08, 2019 (12 KB)
  3. 0.3.0 - November 27, 2018 (10.5 KB)
  4. 0.2.3 - September 04, 2018 (10.5 KB)
  5. 0.2.2 - August 27, 2018 (10.5 KB)
Show all versions (8 total)

Runtime Dependencies (3):

colorize ~> 0.8, >= 0.8.1
net-ssh ~> 5.0, >= 5.0.2
travis ~> 1.8, >= 1.8.2

Development Dependencies (4):

rake ~> 13.0, >= 13.0.1
rspec ~> 3.8, >= 3.8.0
rspec_junit_formatter ~> 0.4, >= 0.4.1
rubocop ~> 0.58, >= 0.58.2

Owners:

Pushed by:

Authors:

  • Levi Bostian

SHA 256 checksum:

= Copy to clipboard Copied!

Total downloads 16,454

For this version 2,912

License:

MIT

Required Ruby Version: >= 0

Links: