RubyGems Navigation menu

array_floe 1.1.2

This small extension to ruby's Array class provides two additional iterators, Array#each_with_floe and Array#each_with_index_floe, that simplify the reasonably-common need to specially handle "floe"--i.e., first, last, odd, even--when iterating through the elements of an array. It's particularly handy for generating CSS classes.

Versions:

  1. 1.1.3 - April 23, 2011 (7.5 KB)
  2. 1.1.2 - April 23, 2011 (8 KB)
  3. 1.1.0 - April 9, 2011 (8 KB)
  4. 1.0.0 - April 9, 2011 (7.5 KB)

Authors:

  • ronen barzel

Owners:

D969a347edb3054c711946c0ed07ce2f

Total downloads 6,776

For this version 1,697

Required Ruby Version: None

Licenses:

N/A

Gemfile:
gem 'array_floe', '~> 1.1.2' = Copy to clipboard Copied!

install:
gem install array_floe -v 1.1.2 = Copy to clipboard Copied!

Links: