RubyGems.org

context

0.0.22

Context is a contextual UI framework. It is based on the Model View Presentor model. The idea is that you have model objects that represent the core data in your application. You also have views that represent the user interface input and output. Finally you have "contexts" that represent a user situation in the application. The logic that ties the models and views resides in the contexts. The main advantages to this model are that you can easily write UI unit tests and you can easily create bridge patterns for supporting multiple widget sets (although only GTK+ is supported at the moment). Context is intended to be extremely minimal. Only the top level abstract classes are included. It is *not* a widget set! You have to write your own models, views and contexts.

installgem install context
Authors

Mike Charlton

3,875 total downloads 1,760 for this version
Owners

8616a8bf5c9ac0db67ac26f89d3b06b6

Gemfile
gem 'context', '~> 0.0.22'
Versions
  1. 0.0.22 January 23, 2011 (32.5 KB)
  2. 0.0.16 September 29, 2008 (94.5 KB)
Runtime Dependencies
  1. gtk2 >= 0