RubyGems Navigation menu

fuzzyrb 1.2.0

DESCRIPTION: Implements Fuzzy Sets in Ruby. I am very beginner at this topic, so it is very basic now. Any help will be appreciated. == FEATURES/PROBLEMS: * Fuzzy Sets defined as sequence of line segments. * Fuzzy Rules. Only conjunction of arguments is possible. * No error handling. * Defuzzification as center of gravity and first maximum * Minimum and Multiplication T-Norms. * Mamdami and Larsen aggregation methods. * Reasoning - apply matching rule and combine the results. Mamdami or Takagi-Sugeno system.

Gemfile
          gem 'fuzzyrb', '~> 1.2.0'
  
  
  
  
  
  
  

install
          gem install fuzzyrb -v 1.2.0
  
  
  
  
  
  
  

Authors:

  • Roman Kamyk

Owners:

Ab46e9ad76540da32912dedaabc2def8

rkj

Total downloads 9,626

For this version 1,568

Show all versions (6 total)

Required Ruby Version: None

Links:

Versions:

  1. 1.2.3 - January 21, 2008 (13.5 KB)
  2. 1.2.2 - November 18, 2007 (13.5 KB)
  3. 1.2.1 - November 18, 2007 (13 KB)
  4. 1.2.0 - November 17, 2007 (13 KB)
  5. 1.1.0 - November 14, 2007 (10.5 KB)
Show all versions (6 total)

Runtime Dependencies: