RubyGems Navigation menu

hybridgroup-ruby-sdl-ffi 0.4.2

Ruby-SDL-FFI is a low-level binding to SDL and related libraries using Ruby-FFI. It provides very basic access to SDL from Ruby without the need for a compiled C wrapper. It aims to be platform and Ruby implementation independent.

Gemfile
          gem 'hybridgroup-ruby-sdl-ffi', '~> 0.4.2'
  
  
  
  
  
  
  

install
          gem install hybridgroup-ruby-sdl-ffi
  
  
  
  
  
  
  

Total downloads 1,150

For this version 558

Required Ruby Version: None

Links:

Versions:

  1. 0.4.2 - February 6, 2014 (36 KB)
  2. 0.4.1 - October 3, 2013 (35.5 KB)

Runtime Dependencies:

Requirements:

SDL >= 1.2.13

SDL_image >= 1.2.7 (optional)

SDL_gfx >= 2.0.13 (optional)

SDL_mixer >= 1.2.8 (optional)

SDL_ttf >= 2.0.9 (optional)