RubyGems Navigation menu

rails_dm_datastore 0.2.16

This gem patches all of the problems that appear from running Rails with DataMapper on the GAE. The main patches are patching DataMapper so that it does not use the ObjectSpace (The ObjectSpace itself is also patched so that this works seamlessly). Also ActiveView is patched so that all of the partial shortcuts work with DataMapper. In addition, a generate is provided (dd_model) that will produce a DataMapper model. One last note is that this gem depends on a dm-core (and other dm gems), dm-appengein, and rails_appengene so all you need is to require this gem in your gem file and you should get all the other gems you need to make DataMapper work with Rails and the GAE.

Gemfile
          gem 'rails_dm_datastore', '~> 0.2.16'
  
  
  
  
  
  
  

install
          gem install rails_dm_datastore
  
  
  
  
  
  
  

Total downloads 24,204

For this version 2,396

Show all versions (18 total)

Required Ruby Version: None

Links:

Versions:

  1. 0.2.17.pre - November 16, 2010 (9.5 KB)
  2. 0.2.16 - October 29, 2010 (9.5 KB)
  3. 0.2.15 - October 29, 2010 (9.5 KB)
  4. 0.2.14 - October 27, 2010 (9.5 KB)
  5. 0.2.13 - October 18, 2010 (9.5 KB)
Show all versions (18 total)

Development Dependencies: