RubyGems Navigation menu

relative-require 1.0

This module changes the meaning of relative requires from "relative to the current pwd" to "relative to the requiring file". By just changing this little thing, it lets you remove lots of uglyness regarding $LOAD_PATH

Versions:

  1. 1.1 - May 18, 2012 (4.5 KB)
  2. 1.0 - November 27, 2010 (4.5 KB)

Authors:

  • Jonas Pfenniger

Owners:

13120f1de7c199861733f2cfd349d860

Total downloads 2,196

For this version 1,271

Required Ruby Version: None

Licenses:

N/A

Gemfile:
gem 'relative-require', '~> 1.0' = Copy to clipboard Copied!

install:
gem install relative-require -v 1.0 = Copy to clipboard Copied!

Links: