RubyGems Navigation menu

relative-require 1.1

This module changes the meaning of relative requires from "relative to the current pwd" to "relative to the requiring file". By just changing this little thing, it lets you remove lots of uglyness regarding $LOAD_PATH

Gemfile
          gem 'relative-require', '~> 1.1'
  
  
  
  
  
  
  

install
          gem install relative-require
  
  
  
  
  
  
  

Authors:

  • Jonas Pfenniger

Owners:

Total downloads 2,155

For this version 904

Required Ruby Version: None

Links:

Versions:

  1. 1.1 - May 18, 2012 (4.5 KB)
  2. 1.0 - November 27, 2010 (4.5 KB)