RubyGems Navigation menu

arduino-library 0.6.0

This library provides a convenient ruby API for representation of an Arduino Library specification, including field and type validation, reading and writing the library.properties file, as well as downloading the official database of Arduino libraries, and offering a highly advanced searching functionality. This gem only offers Ruby API, but for command line usage please checkout the gem called "arli" — Arduino Library Dependency Manager that uses this library behind the scenes.

Versions:

  1. 0.6.0 - August 20, 2018 (17.5 KB)
  2. 0.5.5 - July 04, 2018 (17.5 KB)
  3. 0.5.4 - December 04, 2017 (16.5 KB)
  4. 0.5.3 - November 27, 2017 (16.5 KB)
  5. 0.5.1 - November 27, 2017 (16.5 KB)
Show all versions (14 total)

Runtime Dependencies (5):

Development Dependencies (7):

Owners:

Authors:

  • Konstantin Gredeskoul

SHA 256 checksum:

cf5aedbe75680b52b3cf879510444cfbe77f709f49c08ba479a3d346c5b4d05e

Total downloads 11,348

For this version 1,215

Gemfile:
= Copy to clipboard Copied!

install:
=

License:

MIT

Required Ruby Version: >= 0

Links: