RubyGems Navigation menu

cloudflare-rails 6.0.0

This gem configures Rails for CloudFlare so that request.ip and request.remote_ip and work correctly.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 6.0.0 - June 13, 2024 (14 KB)
  2. 5.0.1 - December 16, 2023 (14 KB)
  3. 5.0.0 - December 15, 2023 (13.5 KB)
  4. 4.1.0 - October 06, 2023 (11.5 KB)
  5. 4.0.0 - August 06, 2023 (11.5 KB)
Show all versions (24 total)

Runtime Dependencies (4):

actionpack >= 7.1.0, < 8.1.0
activesupport >= 7.1.0, < 8.1.0
railties >= 7.1.0, < 8.1.0
zeitwerk >= 2.5.0

Development Dependencies (13):

appraisal ~> 2.5.0
bundler >= 2.4.18
pry-byebug >= 0
rack-attack ~> 6.7.0
rake ~> 13.2.1
rspec ~> 3.13.0
rspec-rails ~> 6.1.2
rubocop ~> 1.64.1
rubocop-rails ~> 2.25.0
rubocop-rspec ~> 2.26.1
webmock ~> 3.23.1

Owners:

Pushed by:

Authors:

  • jonathan schatz

SHA 256 checksum:

= Copy to clipboard Copied!

Total downloads 6,750,202

For this version 9,236

License:

MIT

Required Ruby Version: >= 3.1.0

New versions require MFA: true

Version published with MFA: true

Links: