RubyGems Navigation menu

fig 1.15.0

Fig is a utility for configuring environments and managing dependencies across a team of developers. Given a list of packages and a command to run, Fig builds environment variables named in those packages (e.g., CLASSPATH), then executes the command in that environment. The caller's environment is not affected.

Versions:

  1. 1.27.10 - August 01, 2018 (104 KB)
  2. 1.27.8 - June 18, 2018 (104 KB)
  3. 1.27.5 - June 07, 2018 (104 KB)
  4. 1.27.4 - May 16, 2018 (104 KB)
  5. 1.27.3 - May 16, 2018 (104 KB)
  6. 1.15.0 - February 24, 2014 (95.5 KB)
Show all versions (160 total)

Runtime Dependencies (11):

  • colorize >= 0.5.8
  • highline >= 1.6.19
  • json >= 1.8
  • libarchive-static >= 1.0.0
  • log4r >= 1.1.5
  • net-netrc >= 0.2.2
  • net-sftp >= 2.1.2
  • net-ssh >= 2.6.7
  • open4 >= 1.0.1
  • rdoc >= 4
  • treetop >= 1.4.14
  • Development Dependencies (5):

  • bundler >= 1.0.15
  • rake >= 0.8.7
  • rspec ~> 2
  • simplecov >= 0.6.2
  • simplecov-html >= 0.5.3
  • Owners:

    Authors:

    • Matthew Foemmel

    SHA 256 checksum:

    e59c77cf43183691833435e2e044c26ef1b12ba7027cbe6315827665feadc719

    Total downloads 249,746

    For this version 1,413

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    BSD

    Required Ruby Version: None

    Links: