RubyGems Navigation menu

ftp_paradise 1.2.25

This project aims to provide some convenience bindings and addon-classes for the Ruby-FTP base module. The ruby ftp code is part of the ruby stdlib and you can see its documentation here: http://ruby-doc.org/stdlib/libdoc/net/ftp/rdoc/Net/FTP.html The ftp_paradise project also provides a small GUI wrapper, written in ruby-gnome. This is not complete and has some known bugs, so my recommendation would be to use the commandline variant primarily, until I (or anyone else) goes off to fix the GUI parts. The GUI part resides in the subdirectory gui/ of this project. If you wish to start this, you can try: ftp_paradise --start-gui In general you should be able to use this project whenever you want to quickly upload or download some (remote) files via FTP. In order to facilitate an easier commandline interface, there is a REPL which can be started via typing `iftp` on the commandline. The following summary will give a very short overview over some of the features - for a more complete list, look at the doc/ subdirectory of the gem. We have the ability to download all specific files matching a certain criteria, such as through: download *.xz This will download every remote .xz file that can be found in the remote directory. Remote listing of files can be done via: - rlist or - list2 upload() can be used to upload a local file to a remote webserver, including batch upload (also part of the upload method). Exception handling is done as well. ftp_paradise --help will show some more HELP options. When you pass HELP as first argument to the interactive ftp, we will feedback all the help options available on the commandline.

Versions:

  1. 1.2.25 - November 09, 2019 (78 KB)
Show all versions (223 total)

Owners:

Pushed by:

Authors:

  • Robert A. Heiler

SHA 256 checksum:

58a150914afb7622ee8ac1c943729bc72f36abd44bbe04419b294a338ff8b22e

Total downloads 83,311

For this version 206

Gemfile:
= Copy to clipboard Copied!

install:
=

License:

GPL-2.0

Required Ruby Version: >= 2.6.5

Required Rubygems Version: >= 3.0.6

Links: