RubyGems Navigation menu

google-cloud-policy_troubleshooter-v1 0.5.0

Policy Troubleshooter makes it easier to understand why a user has access to a resource or doesn't have permission to call an API. Given an email, resource, and permission, Policy Troubleshooter will examine all IAM policies that apply to the resource. It then reveals whether the member's roles include the permission on that resource and, if so, which policies bind the member to those roles. Note that google-cloud-policy_troubleshooter-v1 is a version-specific client library. For most uses, we recommend installing the main client library google-cloud-policy_troubleshooter instead. See the readme for more details.

Versions:

  1. 0.5.0 - July 07, 2022 (28 KB)
  2. 0.4.0 - April 20, 2022 (28 KB)
  3. 0.3.5 - January 11, 2022 (26.5 KB)
  4. 0.3.4 - November 08, 2021 (27 KB)
  5. 0.3.3 - August 11, 2021 (27 KB)
Show all versions (11 total)

Runtime Dependencies (3):

Development Dependencies (8):

Owners:

Pushed by:

Authors:

  • Google LLC

SHA 256 checksum:

9d301e502278b229bc1688db9fba48bd04fb690b55fbe1f8beab9581a1fb401c

Total downloads 12,124

For this version 477

Gemfile:
= Copy to clipboard Copied!

install:
=

License:

Apache-2.0

Required Ruby Version: >= 2.6

Links: