RubyGems Navigation menu

kettle-soup-cover 1.0.3

A Covered Kettle of Test Coverage SOUP (Software of Unknown Provenance) Four-line SimpleCov config, w/ curated, opinionated, pre-configured, dependencies

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 1.0.3 - May 23, 2024 (19.5 KB)
  2. 1.0.2 - October 20, 2023 (19.5 KB)
  3. 1.0.1 - October 19, 2023 (18.5 KB)
  4. 1.0.0 - October 19, 2023 (19 KB)
  5. 0.1.0 - October 17, 2023 (16.5 KB)

Runtime Dependencies (8):

simplecov ~> 0.22
simplecov-console ~> 0.9, >= 0.9.1
simplecov-html ~> 0.12
simplecov_json_formatter ~> 0.1, >= 0.1.4
simplecov-rcov ~> 0.3, >= 0.3.3
version_gem ~> 1.1, >= 1.1.3

Development Dependencies (11):

kramdown ~> 2.4
rake ~> 13.0
rspec ~> 3.12
rspec-block_is_expected ~> 1.0, >= 1.0.5
rspec-stubbed_env ~> 1.0, >= 1.0.1
rubocop-lts ~> 18.1, >= 18.2.1
rubocop-packaging ~> 0.5, >= 0.5.2
rubocop-rspec ~> 2.24
yard ~> 0.9, >= 0.9.34
yard-junk ~> 0.0

Owners:

Pushed by:

Authors:

  • Peter Boling

SHA 256 checksum:

= Copy to clipboard Copied!

Signature validity period:

September 20, 2023 - September 19, 2024

Total downloads 2,706

For this version 231

License:

MIT

Required Ruby Version: >= 2.7

New versions require MFA: true

Version published with MFA: true

Links: