RubyGems Navigation menu

ronin-support 1.0.5

ronin-support is a support library for ronin-rb. ronin-support provides many Core Extensions to Ruby's built-in classes as well as its own Classes/Modules. ronin-support can be used by other Ruby libraries, tools, or scripts. It's like pwntools combined with activesupport. ronin-support is part of the ronin-rb project, a Ruby toolkit for security research and development.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 1.0.5 - December 28, 2023 (242 KB)
  2. 1.0.4 - December 16, 2023 (242 KB)
  3. 1.0.3 - September 19, 2023 (242 KB)
  4. 1.0.2 - June 09, 2023 (242 KB)
  5. 1.0.1 - March 02, 2023 (240 KB)
Show all versions (29 total)

Runtime Dependencies (5):

addressable ~> 2.0
chars ~> 0.3, >= 0.3.2
combinatorics ~> 0.4
hexdump ~> 1.0

Development Dependencies (1):

bundler ~> 2.0

Owners:

Pushed by:

Authors:

  • Postmodern

SHA 256 checksum:

f01ec76d5c8f7a9e256f93a7545307b737560f0a969017df2067392c11956bdb

Total downloads 73,256

For this version 926

License:

LGPL-3.0

Required Ruby Version: >= 3.0.0

New versions require MFA: true

Version published with MFA: true

Links: