RubyGems Navigation menu

ronin-support 1.1.0

ronin-support is a support library for ronin-rb. ronin-support provides many Core Extensions to Ruby's built-in classes as well as its own Classes/Modules. ronin-support can be used by other Ruby libraries, tools, or scripts. It's like pwntools combined with activesupport. ronin-support is part of the ronin-rb project, a Ruby toolkit for security research and development.

Gemfile:
= Copier Copié!

installation:
=

Versions:

  1. 1.1.0 - July 22, 2024 (252 ko)
  2. 1.1.0.rc2 - July 14, 2024 (252 ko)
  3. 1.1.0.rc1 - June 23, 2024 (251 ko)
  4. 1.0.7 - July 14, 2024 (244 ko)
  5. 1.0.6 - June 20, 2024 (244 ko)
Voir toutes les versions (34)

Dépendances de Runtime (5):

addressable ~> 2.0
chars ~> 0.3, >= 0.3.2
combinatorics ~> 0.4
hexdump ~> 1.0

Dépendances de Development (1):

bundler ~> 2.0

Propriétaires:

Pushed by:

Auteurs:

  • Postmodern

Total de contrôle SHA 256:

= Copier Copié!

Total de téléchargements 78 784

Pour cette version 338

License:

LGPL-3.0

Version de Ruby requise: >= 3.0.0

New versions require MFA: true

Version published with MFA: true

Liens: