RubyGems Navigation menu

rubocop 0.47.0

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versiones:

  1. 1.18.4 - July 23, 2021 (500 KB)
  2. 1.18.3 - July 06, 2021 (500 KB)
  3. 1.18.2 - July 02, 2021 (500 KB)
  4. 1.18.1 - June 30, 2021 (500 KB)
  5. 1.18.0 - June 29, 2021 (500 KB)
  6. 0.47.0 - January 16, 2017 (300 KB)
Mostrar todas las versiones (185 total)

dependencias de Runtime (5):

  • parser < 3.0, >= 2.3.3.1
  • powerpack ~> 0.1
  • rainbow < 3.0, >= 1.99.1
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.0.1, ~> 1.0
  • dependencias de Development (1):

  • bundler ~> 1.3
  • Propietarios:

    Autores:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    55d32c0b5b42f7ac5b6ede9ef4f6a1e6605bc28f8cb38db1c796042ad71f5bd3

    Total de descargas 171.605.222

    Para esta versión 93.134

    Gemfile:
    = Copiar al portapapeles ¡Copiado!

    instalar:
    =

    Licencia:

    MIT

    Versión de Ruby requerida: >= 2.0.0

    Enlace: