RubyGems Navigation menu

em_pessimistic 0.2.0

EventMachine's built-in popen does not provide access to stderr. Likewise, it's DeferrableChildProcess does not use an errback for when the process fails. This gem fixes both of those mistakes.

Gemfile
          gem 'em_pessimistic', '~> 0.2.0'
  
  
  
  
  
  
  

install
          gem install em_pessimistic
  
  
  
  
  
  
  

Authors:

  • Christian Johansen, Andrey Chergik

Owners:

Total downloads 4,368

For this version 1,375

Required Ruby Version: None

Links:

Versions:

  1. 0.2.0 - February 4, 2013 (5.5 KB)
  2. 0.1.2 - September 18, 2012 (5 KB)
  3. 0.1.1 - September 16, 2012 (5 KB)
  4. 0.1.0 - September 16, 2012 (3.5 KB)

Runtime Dependencies: