RubyGems Navigation menu

autoproj 1.6.0.rc1

What is Autoproj ---------------- Autoproj allows to easily install and maintain software that is under source code form (usually from a version control system). It has been designed to support a package-oriented development process, where each package can have its own version control repository (think "distributed version control"). It also provides an easy integration of the local operating system (Debian, Ubuntu, Fedora, maybe MacOSX at some point). This tool has been developped in the frame of the RubyInMotion project (http://sites.google.com/site/rubyinmotion), to install robotics-related software -- that is often bleeding edge. Unlike [the ROS build system](http://ros.org), it is not bound to one build system, one VCS and one integration framework. The philosophy behind autoproj is: * supports both CMake and autotools, and can be adapted to other tools * supports different VCS: cvs, svn, git, plain tarballs. * software packages are plain packages, meaning that they can be built and installed /outside/ an autoproj tree, and are not tied *at all* to the autoproj build system. * leverage the actual OS package management system. Right now, only Debian-like systems (like Ubuntu) are supported, simply because it is the only one I have access to. * handle code generation properly

版本列表:

  1. 2.12.1 - April 23, 2020 (201.5 KB)
  2. 2.12.0 - February 27, 2020 (201.0 KB)
  3. 2.11.0 - October 03, 2019 (191.5 KB)
  4. 2.10.2 - August 07, 2019 (189.0 KB)
  5. 2.10.1 - June 03, 2019 (188.5 KB)
  6. 1.6.0.rc1 - July 23, 2010 (102.5 KB)
显示所有 (333 个版本)

Runtime 依赖关系 (5):

  • autobuild >= 1.5.9
  • highline >= 1.5.0
  • nokogiri >= 1.3.3
  • rmail >= 1.0.0
  • utilrb >= 1.3.3
  • Development 依赖关系 (4):

  • hoe >= 2.6.1
  • rdoc >= 2.4.0
  • rubyforge >= 2.0.4
  • webgen >= 0.5.9
  • 所有者:

    作者:

    • Sylvain Joyeux

    SHA 256 checksum:

    3be73747496b7f452db2c9dbfd8060918cba67205c685d74d4dac642144dd403

    下载总次数 538,501

    这个版本 1,651

    Gemfile:
    = 复制到剪贴板 已复制

    安装:
    =

    许可s:

    需要的 Ruby 版本:

    需要的 RubyGems 版本: > 1.3.1

    相关链接: