RubyGems Navigation menu

cf-uaac 3.1.5

Client command line tools for interacting with the CloudFoundry User Account and Authorization (UAA) server. The UAA is an OAuth2 Authorization Server so it can be used by webapps and command line apps to obtain access tokens to act on behalf of users. The tokens can then be used to access protected resources in a Resource Server. This library can be used by clients (as a convenient wrapper for mainstream oauth gems) or by resource servers.

Versies:

  1. 4.2.0 - August 27, 2019 (135 KB)
  2. 4.1.0 - November 01, 2017 (135 KB)
  3. 4.0.0 - August 24, 2017 (135 KB)
  4. 3.13.1 - July 28, 2017 (135 KB)
  5. 3.13.0 - July 10, 2017 (135 KB)
  6. 3.1.5 - December 01, 2015 (131 KB)
Toon alle versies (35 totaal)

Runtime afhankelijkheden (7):

  • cf-uaa-lib ~> 3.2.5
  • em-http-request ~> 1.1.2
  • eventmachine ~> 1.0.3
  • highline ~> 1.6.21
  • json_pure ~> 1.8.1
  • launchy ~> 2.4.2
  • rack ~> 1.5.2
  • Development afhankelijkheden (6):

  • bundler >= 0
  • ci_reporter ~> 1.9.2
  • rake ~> 10.3.1
  • rspec ~> 2.14.1
  • simplecov ~> 0.8.2
  • simplecov-rcov ~> 0.2.3
  • Eigenaren:

    Authors:

    • Dave Syer, Dale Olds, Joel D'sa, Vidya Valmikinathan, Luke Taylor

    SHA 256 checksum:

    15de2080498913791a231a0cad11f1fed33676a1a02a1526aec8dcdfb93542bb

    Total downloads 1.718.445

    Voor deze versie 3.531

    Gemfile:
    = Copy to clipboard Copied!

    Installeer:
    =

    License:

    Apache 2.0

    Required Ruby Version: >= 0

    Links: