RubyGems Navigation menu

metasploit_data_models 1.0.0.pre.rails.pre.4.0a

Implements minimal ActiveRecord models and database helper code used in both the Metasploit Framework (MSF) and Metasploit commercial editions.

Versions:

  1. 5.0.2 - June 07, 2021 (175 KB)
  2. 5.0.1 - May 11, 2021 (175 KB)
  3. 5.0.0 - April 29, 2021 (175 KB)
  4. 4.1.4 - April 29, 2021 (175 KB)
  5. 4.1.3 - April 08, 2021 (175 KB)
  6. 1.0.0.pre.rails.pre.4.0a - April 29, 2015 (155 KB)
Show all versions (182 total)

Runtime Dependencies (9):

  • activerecord < 4.1.0, >= 4.0.9
  • activesupport < 4.1.0, >= 4.0.9
  • arel-helpers >= 0
  • metasploit-concern = 1.0.0.pre.rails.pre.4.0
  • metasploit-model = 1.0.0.pre.rails.pre.4.0
  • pg >= 0
  • postgres_ext >= 0
  • railties < 4.1.0, >= 4.0.9
  • recog ~> 1.0
  • Development Dependencies (4):

  • pry >= 0
  • rake >= 0
  • redcarpet >= 0
  • yard < 0.8.7.4
  • Owners:

    Authors:

    • Samuel Huckins, Luke Imhoff, David 'thelightcosine' Maloney, Trevor 'burlyscudd' Rosen

    SHA 256 checksum:

    3c1a2966731840a23c23b539ed9a81f0b3fc70bd21b94a98b02ef978951b54dd

    Total downloads 2,256,163

    For this version 1,036

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    Licenses:

    N/A

    Required Ruby Version: >= 2.1

    Required Rubygems Version: > 1.3.1

    Links: