RubyGems Navigation menu

puppetlabs_spec_helper 7.0.5

Contains rake tasks and a standard spec_helper for running spec tests on puppet modules.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 7.1.0 - March 12, 2024 (28.5 KB)
  2. 7.0.5 - February 09, 2024 (28.5 KB)
  3. 7.0.4 - February 08, 2024 (28.5 KB)
  4. 7.0.3 - January 24, 2024 (28.5 KB)
  5. 7.0.2 - December 12, 2023 (28.5 KB)
Show all versions (79 total)

Runtime Dependencies (6):

mocha ~> 1.0
pathspec >= 0.2, < 2.0.0
puppet-lint ~> 4.0
puppet-syntax ~> 4.0
rspec-github ~> 2.0
rspec-puppet ~> 4.0

Requirements:

puppet, >= 7.0.0

Owners:

Pushed by:

Authors:

  • Puppet, Inc., Community Contributors

SHA 256 checksum:

2a0415f5f9aaa7fa6f645c9f44d18ca488aeda71b17486f725a99874da1fe5c3

Total downloads 14,192,771

For this version 13,457

License:

Apache-2.0

Required Ruby Version: >= 2.7

Links: