RubyGems Navigation menu

rdf-reasoner 0.6.2

Reasons over RDFS/OWL vocabularies to generate statements which are entailed based on base RDFS/OWL rules along with vocabulary information. It can also be used to ask specific questions, such as if a given object is consistent with the vocabulary ruleset. This can be used to implement SPARQL Entailment Regimes.

Versions:

  1. 0.6.2 - July 10, 2020 (15 KB)
  2. 0.6.1 - May 30, 2020 (15 KB)
  3. 0.6.0 - December 16, 2019 (15 KB)
  4. 0.5.3 - November 12, 2019 (15 KB)
  5. 0.5.2 - April 27, 2019 (15 KB)
Show all versions (22 total)

Runtime Dependencies (3):

  • rdf ~> 3.1, >= 3.1.2
  • rdf-vocab ~> 3.1, >= 3.1.5
  • rdf-xsd ~> 3.1
  • Development Dependencies (6):

  • equivalent-xml ~> 0.6
  • json-ld ~> 3.1
  • rdf-spec ~> 3.1
  • rdf-turtle ~> 3.1
  • rspec ~> 3.9
  • yard ~> 0.9.20
  • Owners:

    Pushed by:

    Authors:

    • Gregg Kellogg

    SHA 256 checksum:

    f3324d691528837145740183ec1dd2a27267b3ca9240f241f91de462d6bc5bdf

    Total downloads 214,601

    For this version 1,866

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    Unlicense

    Required Ruby Version: >= 2.4

    Links: