RubyGems Navigation menu

rdf-reasoner 0.8.0

Reasons over RDFS/OWL vocabularies to generate statements which are entailed based on base RDFS/OWL rules along with vocabulary information. It can also be used to ask specific questions, such as if a given object is consistent with the vocabulary ruleset. This can be used to implement SPARQL Entailment Regimes.

Versions:

  1. 0.8.0 - December 29, 2021 (16 KB)
  2. 0.7.2 - February 27, 2021 (16 KB)
  3. 0.7.1 - February 18, 2021 (15.5 KB)
  4. 0.7.0 - February 16, 2021 (15.5 KB)
  5. 0.6.2 - July 10, 2020 (15 KB)
Show all versions (26 total)

Runtime Dependencies (2):

  • rdf ~> 3.2
  • rdf-xsd ~> 3.2
  • Development Dependencies (7):

    Owners:

    Pushed by:

    Authors:

    • Gregg Kellogg

    SHA 256 checksum:

    ac451631c1f2d71513d5692faa3dbbb97a82125414a949976d655bffa65f4398

    Total downloads 328,905

    For this version 20,982

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    Unlicense

    Required Ruby Version: >= 2.6

    Links: