RubyGems Navigation menu

rubocop 0.34.0

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.10.0 - February 15, 2021 (469 ko)
  2. 1.9.1 - February 01, 2021 (467 ko)
  3. 1.9.0 - January 28, 2021 (466 ko)
  4. 1.8.1 - January 11, 2021 (459 ko)
  5. 1.8.0 - January 07, 2021 (459 ko)
  6. 0.34.0 - September 05, 2015 (288 ko)
Voir toutes les versions (171)

Dépendances de Runtime (5):

  • astrolabe ~> 1.3
  • parser < 3.0, >= 2.2.2.5
  • powerpack ~> 0.1
  • rainbow < 3.0, >= 1.99.1
  • ruby-progressbar ~> 1.4
  • Dépendances de Development (5):

  • bundler ~> 1.3
  • rake ~> 10.1
  • rspec ~> 3.2.0
  • simplecov ~> 0.10
  • yard ~> 0.8
  • Propriétaires:

    Auteurs:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    Total de contrôle SHA 256:

    e704f43bc99114ca93d78cef7937d5a7aebde105613bf82ec86612a8efb44bc3

    Total de téléchargements 143 663 326

    Pour cette version 57 704

    Gemfile:
    = Copier Copié!

    installation:
    =

    License:

    MIT

    Version de Ruby requise: >= 1.9.3

    Liens: