RubyGems Navigation menu

wrest 1.5.4

Wrest is a fluent, easy-to-use, object oriented Ruby HTTP/REST client library with support for RFC2616 HTTP caching, multiple HTTP backends and async calls using EventMachine. It runs on CRuby and JRuby.

Versions:

  1. 1.5.4 - August 5, 2015 (42 KB)
  2. 1.5.3 - August 4, 2015 (42 KB)
  3. 1.5.2 - July 11, 2015 (41 KB)
  4. 1.5.1 - June 23, 2015 (40.5 KB)
  5. 1.5.0 - December 9, 2011 universal-java-1.6 (41 KB)
Show all versions (64 total)

Requirements:

To use Memcached as caching back-end, install the 'dalli' gem.

To use multipart post, install the 'multipart-post' gem.

To use curl as the http engine, install the 'patron' gem. This feature is not available (and should be unneccessary) on jruby.

To use eventmachine as a parallel backend, install the 'eventmachine' gem.

Authors:

  • Sidu Ponnappa, Niranjan Paranjape

Owners:

7bb0d7e74198c735783b8a65cd14989cC6b11d78198b990ecd517a3f49518ca0E7b02f93158e77deb0b0e316efec93212e45ce1ec733f588158cdf54c736c13d60b6f2cf039ba1b40066b6a2d445b6f8

Sha 256 checksum:

53e424b9be95fb8964e9f0a8bb5f05b54d203b72571bad95d72857f23ba01da7

Total downloads 83,261

For this version 248

Show all versions (64 total)

Required Ruby Version: >= 0

Licenses:

N/A

Gemfile:
= Copy to clipboard Copied!

install:
= Copy to clipboard Copied!

Links: