RubyGems Navigation menu

wrest 2.1.7

Wrest is a fluent, easy-to-use, object oriented Ruby HTTP/REST client library with support for RFC2616 HTTP caching, multiple HTTP backends and async calls using EventMachine. It runs on CRuby and JRuby.

Versions:

  1. 3.0.0 - April 20, 2018 (39 KB)
  2. 2.2.0 - April 24, 2017 (39 KB)
  3. 2.1.9 - January 13, 2017 (39 KB)
  4. 2.1.7 - April 22, 2016 (39 KB)
  5. 2.1.6 - April 21, 2016 (39 KB)
Show all versions (75 total)

Runtime Dependencies (3):

Development Dependencies (3):

  • metric_fu >= 0
  • rspec ~> 3.3
  • sinatra ~> 1.0.0
  • Requirements:

    To use Memcached as caching back-end, install the 'dalli' gem.

    To use multipart post, install the 'multipart-post' gem.

    To use curl as the http engine, install the 'patron' gem. This feature is not available (and should be unneccessary) on jruby.

    To use eventmachine as a parallel backend, install the 'eventmachine' gem.

    Owners:

    Authors:

    • Sidu Ponnappa, Niranjan Paranjape

    SHA 256 checksum:

    25180494ec4ec104468356941340d8090a7b16f3a4cdff715f62b9d52197da2e

    Total downloads 203,713

    For this version 5,482

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    Licenses:

    N/A

    Required Ruby Version: >= 0

    Required Rubygems Version: >= 1.3.0

    Links: