RubyGems Navigation menu

acread 0.5.0

When you deprecate an attribute, acread can helps you in 3 ways : 1. helps you finding where you are using this attribute by creating glue to raise a `DeprecatedAttributeError`. 2. ignore this atribute when serializing the object through to_json, to_xml ... 3. helps your zero downtime migration by ignoring the attribute for objects already in memory when saving to database.

Gemfile
          gem 'acread', '~> 0.5.0'
  
  
  
  
  
  
  

install
          gem install acread -v 0.5.0
  
  
  
  
  
  
  

Total downloads 34,436

For this version 5,097

Show all versions (7 total)

Required Ruby Version: None

Links:

Versions:

  1. 0.6.2 - February 18, 2013 (8 KB)
  2. 0.6.1 - February 18, 2013 (8 KB)
  3. 0.6.0 - February 18, 2013 (8 KB)
  4. 0.5.3 - December 6, 2012 (7.5 KB)
  5. 0.5.2 - December 6, 2012 (7.5 KB)
Show all versions (7 total)

Runtime Dependencies: