RubyGems Navigation menu

aws-sdk 3.0.0.rc7

The official AWS SDK for Ruby. Provides both resource oriented interfaces and API clients for AWS services.

Versions:

  1. 3.0.1 - August 31, 2017 (4.5 KB)
  2. 3.0.0 - August 29, 2017 (4.5 KB)
  3. 3.0.0.rc9 - June 26, 2017 (4.5 KB)
  4. 3.0.0.rc8 - May 23, 2017 (8 KB)
  5. 3.0.0.rc7 - May 05, 2017 (8 KB)
Show all versions (514 total)

Runtime Dependencies (98):

aws-sdk-acm = 1.0.0.rc3 aws-sdk-apigateway = 1.0.0.rc4 aws-sdk-applicationautoscaling = 1.0.0.rc2 aws-sdk-applicationdiscoveryservice = 1.0.0.rc3 aws-sdk-appstream = 1.0.0.rc3 aws-sdk-autoscaling = 1.0.0.rc2 aws-sdk-batch = 1.0.0.rc2 aws-sdk-budgets = 1.0.0.rc3 aws-sdk-clouddirectory = 1.0.0.rc2 aws-sdk-cloudformation = 1.0.0.rc3 aws-sdk-cloudfront = 1.0.0.rc3 aws-sdk-cloudhsm = 1.0.0.rc2 aws-sdk-cloudsearch = 1.0.0.rc2 aws-sdk-cloudsearchdomain = 1.0.0.rc3 aws-sdk-cloudtrail = 1.0.0.rc4 aws-sdk-cloudwatch = 1.0.0.rc2 aws-sdk-cloudwatchevents = 1.0.0.rc2 aws-sdk-cloudwatchlogs = 1.0.0.rc3 aws-sdk-codebuild = 1.0.0.rc4 aws-sdk-codecommit = 1.0.0.rc3 aws-sdk-codedeploy = 1.0.0.rc4 aws-sdk-codepipeline = 1.0.0.rc3 aws-sdk-codestar = 1.0.0.rc1 aws-sdk-cognitoidentity = 1.0.0.rc4 aws-sdk-cognitoidentityprovider = 1.0.0.rc3 aws-sdk-cognitosync = 1.0.0.rc2 aws-sdk-configservice = 1.0.0.rc5 aws-sdk-costandusagereportservice = 1.0.0.rc4 aws-sdk-databasemigrationservice = 1.0.0.rc3 aws-sdk-datapipeline = 1.0.0.rc2 aws-sdk-devicefarm = 1.0.0.rc2 aws-sdk-directconnect = 1.0.0.rc4 aws-sdk-directoryservice = 1.0.0.rc3 aws-sdk-dynamodb = 1.0.0.rc4 aws-sdk-dynamodbstreams = 1.0.0.rc3 aws-sdk-ec2 = 1.0.0.rc4 aws-sdk-ecr = 1.0.0.rc3 aws-sdk-ecs = 1.0.0.rc4 aws-sdk-efs = 1.0.0.rc3 aws-sdk-elasticache = 1.0.0.rc3 aws-sdk-elasticbeanstalk = 1.0.0.rc5 aws-sdk-elasticloadbalancing = 1.0.0.rc2 aws-sdk-elasticloadbalancingv2 = 1.0.0.rc3 aws-sdk-elasticsearchservice = 1.0.0.rc3 aws-sdk-elastictranscoder = 1.0.0.rc2 aws-sdk-emr = 1.0.0.rc2 aws-sdk-firehose = 1.0.0.rc4 aws-sdk-gamelift = 1.0.0.rc3 aws-sdk-glacier = 1.0.0.rc2 aws-sdk-health = 1.0.0.rc4 aws-sdk-iam = 1.0.0.rc4 aws-sdk-importexport = 1.0.0.rc2 aws-sdk-inspector = 1.0.0.rc3 aws-sdk-iot = 1.0.0.rc2 aws-sdk-iotdataplane = 1.0.0.rc2 aws-sdk-kinesis = 1.0.0.rc2 aws-sdk-kinesisanalytics = 1.0.0.rc2 aws-sdk-kms = 1.0.0.rc4 aws-sdk-lambda = 1.0.0.rc5 aws-sdk-lambdapreview = 1.0.0.rc2 aws-sdk-lex = 1.0.0.rc1 aws-sdk-lexmodelbuildingservice = 1.0.0.rc1 aws-sdk-lightsail = 1.0.0.rc3 aws-sdk-machinelearning = 1.0.0.rc2 aws-sdk-marketplacecommerceanalytics = 1.0.0.rc3 aws-sdk-marketplaceentitlementservice = 1.0.0.rc1 aws-sdk-marketplacemetering = 1.0.0.rc2 aws-sdk-mturk = 1.0.0.rc3 aws-sdk-opsworks = 1.0.0.rc2 aws-sdk-opsworkscm = 1.0.0.rc4 aws-sdk-organizations = 1.0.0.rc2 aws-sdk-pinpoint = 1.0.0.rc3 aws-sdk-polly = 1.0.0.rc4 aws-sdk-rds = 1.0.0.rc6 aws-sdk-redshift = 1.0.0.rc2 aws-sdk-rekognition = 1.0.0.rc6 aws-sdk-resourcegroupstaggingapi = 1.0.0.rc1 aws-sdk-route53 = 1.0.0.rc4 aws-sdk-route53domains = 1.0.0.rc2 aws-sdk-s3 = 1.0.0.rc5 aws-sdk-servicecatalog = 1.0.0.rc2 aws-sdk-ses = 1.0.0.rc2 aws-sdk-shield = 1.0.0.rc3 aws-sdk-simpledb = 1.0.0.rc2 aws-sdk-sms = 1.0.0.rc2 aws-sdk-snowball = 1.0.0.rc4 aws-sdk-sns = 1.0.0.rc2 aws-sdk-sqs = 1.0.0.rc5 aws-sdk-ssm = 1.0.0.rc4 aws-sdk-states = 1.0.0.rc1 aws-sdk-storagegateway = 1.0.0.rc4 aws-sdk-support = 1.0.0.rc2 aws-sdk-swf = 1.0.0.rc2 aws-sdk-waf = 1.0.0.rc4 aws-sdk-wafregional = 1.0.0.rc4 aws-sdk-workdocs = 1.0.0.rc2 aws-sdk-workspaces = 1.0.0.rc2 aws-sdk-xray = 1.0.0.rc3

Authors:

  • Amazon Web Services

Owners:

Dcbdc27226eb6a81330730ab58b84d986d8609aeb8226526d74f2c6857cc1169

SHA 256 checksum:

0236c291fe114e456c92db4614c8510f0ceccbf08031a7178c22aac0a86cd367

Total downloads 66,533,313

For this version 2,076

Gemfile:
= Copy to clipboard Copied!

install:
=

License:

Apache-2.0

Required Ruby Version: >= 0

Required Rubygems Version: > 1.3.1

Links: